American Express Card Enrolment Timeouts
Incident Report for Fidel API
Resolved
American Express have advised that they have identified and resolved the issue on their end.
Posted Mar 15, 2024 - 17:12 GMT
Investigating
We have been experiencing an increased number of timeouts for American Express card enrolments since 4am UTC. The issue has been escalated to the network for investigation.
Posted Mar 01, 2024 - 16:28 GMT
This incident affected: External Connectivity (American Express).