Mastercard onboarding delays
Incident Report for Fidel API
Resolved
Mastercard are caught up on data processing and onboarding has resumed normal turnaround times.
Posted Aug 24, 2022 - 21:24 BST
Monitoring
Mastercard merchant onboarding is currently delayed, with no new locations synced since 18 July. Mastercard are currently processing missing data to catch up with these delays. These delays are due to higher than normal request volume during this period. We will continue to monitor the situation and share an update when they are fully caught up with data processing.
Posted Jul 25, 2022 - 16:05 BST
This incident affected: External Connectivity (Mastercard).