Visa Transaction Processing Delay
Incident Report for Fidel
Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 15:49 GMT
Update
Last Visa transaction processed is dated 18/11/19 of November.
Posted Nov 21, 2019 - 19:30 GMT
Identified
We are currently experiencing a delay on Visa daily clearing transaction processing. Last received Visa transaction is dated 15th of November. Visa is aware of the delay and is working to resume the 48h clearing cycle in the next few days.
Posted Nov 19, 2019 - 18:58 GMT
This incident affected: API.