Mastercard data delays
Incident Report for Fidel API
Resolved
We are continuing to monitor as Mastercard catches up with clearing and onboarding data. Updates from here on will move to our new Statuspage component for Mastercard issues, as this does not affect our Transaction Select API.
Posted Dec 10, 2021 - 15:04 GMT
Monitoring
Mastercard are currently processing missing data through November 18 to catch up with these delays. These delays are due to higher than normal request volume during this period. We will continue to monitor the situation and share an update when they are fully caught up with data processing.
Posted Nov 23, 2021 - 16:39 GMT
Investigating
We are investigating ongoing delays with Mastercard data affecting the following:
- Missing Mastercard clearing data since November 11
- Merchant onboarding delays with no new locations synced with Mastercard since November 11

Visa and Amex transactions are not affected. We have escalated this to our partners at Mastercard and will share an update when we have a resolution.
Posted Nov 19, 2021 - 16:05 GMT
This incident affected: API (Select Transactions API).