VISA Transactions Delay
Incident Report for Fidel API
Resolved
VISA clearing transactions processing issue fixed. We are double checking and confirming deliverability of all delayed transactions. 48h VISA clearing cycle will be restored from April 13th 12:00 UTC
Posted Apr 12, 2018 - 14:45 BST
Monitoring
We are monitoring an issue with Visa clearing transactions. Visa transaction processing is currently with a 4 day delay. We working to process all missing transactions and restore the normal 48h clearing cycle.
Posted Apr 09, 2018 - 13:50 BST