Mastercard Card Linking Service
Incident Report for Fidel
Resolved
This is incident has been resolved. All Mastercard card linking services are operational.
Posted 12 months ago. May 29, 2018 - 16:17 BST
Investigating
Due to a technical issue on Mastercard infrastructure, we are not able to link new Mastercard cards at the moment. All card linking requests are being logged and can be re-linked when systems are operational. Mastercard is working to fix the issue.
Posted 12 months ago. May 29, 2018 - 15:44 BST
This incident affected: API.