Mastercard Card Linking Errors
Incident Report for Fidel
Resolved
This incident has been resolved.
Posted about 1 year ago. Sep 06, 2018 - 14:32 BST
Monitoring
Mastercard experienced issues linking cards on Friday 17th, we've been monitoring the issue since then and are working to Mastercard to confirm the issues has been resolved. This will cause a 3 day delay on receiving Mastercard transactions since the 17th.
Posted about 1 year ago. Aug 20, 2018 - 10:11 BST