VISA Transaction Processing Delay
Incident Report for Fidel API
Resolved
This incident has been resolved.
Posted May 11, 2018 - 11:10 BST
Monitoring
Visa transaction processing is currently with a 4 day delay. We are working with VISA to process all delayed transactions and restore the normal 48h clearing cycle shortly.
Posted May 07, 2018 - 13:52 BST